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2 Product description, program requirements 

2.1 Brief product description 

The ID Microserver 2 program (pic. 1) is used 
for connecting local readers to a PC via serial 
port, USB or TCP/IP converter and for 
distribution of IDs read by connected readers 
to other TECHFASS programs via TCP/IP, or 
to get the IDs in Windows environment using 
keyboard buffer or clipboard. 

The program is able to handle multiple 
readers connected to a PC at the same time. 

 

 

 

2.2 Hardware and software requirements 

For connecting a reader, it is necessary to connect appropriate TCP/IP / COM converter 
to the network with a server running the program or connect the reader directly to a COM 
or USB port of the computer. The program requires Windows 10 / 11 and 
.NET Framework version 4.6.1 to run. 

2.3 Supported readers 

The program supports following reader types: 

 REM 181.USB, REM 281.USB, 
 USBREM 02, 
 Lektor D-1-USB, R1U I-LG, 
 OCR 312, OCR 315, 
 Omnikey Reader (5125, 5321, 5325 CL), 
 Idesco Access7C2 (serial port, TCP/IP), 
 APSLAN (WIEGAND mode) (reader with WIEGAND output connected through 

APSLAN converter), 
 UB 2100, 
 System reader (system reader communicating with APS Server program). 

  

Pic. 1: ID Microserver 2 application 
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3 Program installation 

The program is installed by running the installer. 

When connecting the readers to a PC follow the recommended installation instructions 
supplied with the specific reader. Any USB device requires installation of appropriate 
driver as a rule. Drivers for all supported USB readers are available at www.techfass.cz. 

Run the program by its shortcut from the Start menu. 

Program contains following tabs: 

 Configuration tab (pic.1) contains configuration parameters for the program operation. 
 Application server status tab (pic.2) contains information about connected clients and 

read IDs. 

 

Pic. 2: Application server status 
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4 Program configuration 

The Configuration tab contains a tree of configurable properties of the ID Microserver 2 
program. 

The root element Server contains the setting of parameters for client programs, which can 
connect to the ID Microserver 2 program. The Application element contains a series of 
options for working with the read ID, when the program operates in application mode (not 
applicable when operating as a system service). The Service element contains resources 
for TF.IDMicroserver2.Service Windows service administration. The Readers element 
enables to add and configure supported readers; after adding a reader, it is necessary to 
configure its operating parameters. 

4.1 Server 

The root element Server (pic. 3) contains the setting of 
operating parameters for the server: 

 IP Port – IP port, on which the server listens and receives 
the connections from client programs; the default IP port 
value is 10777. 

 Remote connections enabled – a list of addresses, from 
which the remote connections to the server are accepted; 
the program enables the connection of clients with IP 
address listed in the Allowed clients list only; the other 
connections are refused (relevant record can be found in 
the program log). 

  

Pic. 3: Server 
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4.2 Application 

The Application element (pic. 4) contains a series 
of options for working with the read ID, when the 
program operates in application mode (not 
applicable when operating as a system service).  

 Copy data to clipboard – when using this 
option, the data read at the PC reader are 
saved in the computer clipboard. The data can 
be pasted from the clipboard into any text field 
by the Paste command.  

 Send to keyboard buffer, append characters – 
when this option is used, the data read at the 
PC reader are directly sent to the keyboard buffer. As a result the ID code is 
immediately written at the cursor position. 

 Interpret data in decimal format – by default the data is interpreted in hexadecimal 
format. If the decimal format of the read data is required, press the relevant choice, 
the program will automatically perform the conversion. 

 Code length – the program works with the full code length by default. If there is need 
to shorten / extend the code, check the proper checkbox and set the code length 
(characters count). If the set code length is higher than the read code, you can check 
the Append leading zeroes option to extend the code from left with zeroes to get 
required length. 

 Append characters – if you need to add any characters in front or behind the read ID, 
fill it in the Prefix and/or Suffix field. The data is entered as a comma separated list of 
bytes (ASCII codes). The control characters can be used as well, typically: 0D – 
carriage return; 0A – line feed. 

 After application start: start communication and minimize to tray – if the option is 
selected, the program is automatically minimized to system tray and the 
communication is automatically started after the application is run. 

4.3 Service 

The program is able to operate as a standard Windows 
service. The Service element (pic. 5) contains all 
resources for the TF.IDMicroserver2.Service service 
administration. 

All operations with the Windows services require 
Administrator privileges at the computer. 

 Service name: TF.IDMicroserver2.Service – name of the service. 
 Service status – the status of the service; if Unknown / not installed value is 

displayed, the service is either not installed, or you do not have sufficient rights to 
display the service status. 

 Install service – after the button is pressed, the service is installed; the service is 
installed to be run after the computer is started. 

 Start service – after the button is pressed, the service is manually started. 
 Stop service – after the button is pressed, the service is stopped manually. 
 Uninstall service – after the button is pressed the service is uninstalled. 

Pic. 4: Application 

Pic. 5: Service 



 

Page 7 

4.4 Readers 

The Readers element (pic. 6) enables to add 
supported readers into the program configuration 
and to set the operational parameters for individual 
readers in the configuration. 

4.4.1 REM 181.USB, REM 281.USB 

Connecting the REM 181.USB (resp. REM 
281.USB) reader using USB port; after installation 
of the drivers the reader gets a virtual COM port 
assigned; when configuring the reader, select 
COM port in the relevant field. 

4.4.2 USBREM 02 

Connecting the USBREM 02 reader using USB 
port; after installation of the drivers the reader gets 
a virtual COM port assigned; when configuring the 
reader, select COM port in the relevant field. 

4.4.3 Access7C2 (serial port) 

Connecting the IDESCO Access7C2 reader 
directly using a serial port of a computer; when 
configuring the reader properties, select the COM 
port in the relevant field. 

4.4.4 Access7C2 using TCP/IP 

Connecting the IDESCO Access7C2 reader using 
a TCP/IP converter (e.g. GNOME 232); when 
configuring the reader properties, fill in IP address 
and IP port parameters of the converter in relevant 
fields. 

4.4.5 APSLAN (WIEGAND mode) 

Connecting a reader with WIEGAND output using 
APSLAN converter in Wiegand -> TCP/IP operation mode; when configuring the reader 
properties, fill in IP address and IP port parameters of the APSLAN in relevant fields. 

4.4.6 Omnikey Reader 

Connecting Omnikey reader 5321, 5325 CL, or 5215 using USB port; after installion of the 
drivers the reader is displayed in the Device manager; when configuring the reader 
properties, select relevant reader in the list. 

4.4.7 Lektor D-1-USB 

Connecting the Lektor D-1-USB reader using USB port; after installation of the drivers the 
reader gets a virtual COM port assigned; when configuring the reader, select COM port in 
the relevant field.  

Pic. 6: Supported readers 
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4.4.8 MREM 21 

Connecting MREM 21 reader directly using a serial port of a computer; when configuring 
the reader properties, select the COM port in the relevant field. 

The MREM 21 reader is not supported on OS Windows 7 and newer! 

4.4.9 OCR 31x 

Connecting OCR 31x OCR document reader using USB port; after installation of the 
drivers the reader gets a virtual COM port assigned; when configuring the reader, select 
COM port in the relevant field. If the reader is set not to provide the document type on its 
own, select the Insert document type (ID) option. 

4.4.10 UB 2100 

Connecting the UB 2100 reader using USB port; after installation of the drivers the reader 
gets a virtual COM port assigned; when configuring the reader, select COM port in the 
relevant field. 

4.4.11 System reader 

The program enables to use any APS mini Plus or APS 400 system reader as a table-top 
reader. To do so, you have to use the APS Administrator solution to manage the system 
and the reader has to be communicating with the APS Server program. 

When configuring the setting, you have to enter the IP address and IP port of the APS 
Server application (service). Additionally, you have to enter the system ID and the HW 
address of selected reader. 
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4.5 User data format 

Readers supporting standard ID code 
reading can be configured to alter the read 
code in User data format (pic. 7). Such 
function is meaningful only in cases when 
codes of ID media read at system readers 
differ from the codes read at the enrolment 
reader, e. g. by inappropriate interpretation 
of parity bits or by some reverse operation 
set at the system readers. 

To enable the function, select the proper 
Card type (available only for selected PC 
readers) and check the User data format checkbox. The program will consider only the 
data from the range given by the First Data Bit and Last Data Bit to be a valid code to use 
(for selected Card type), starting with index 0. 

Example: The standard length of EM Marin technology ID media is 40bits; if you need to 
use the entire code, it is necessary to set the range to 0 ÷ 39. 

In the next step the cut code is handled with the options selected below. 

The first option is to suppress the use the Crosspoint algorithm (Crosspoint code 
interpretation disabled), which is standardly applied to IDs in proper format (5byte EM 
Marin cards with MSBs: 0F, 00; or 01, 00), which are transferred to a 24bit code in 
compliance to the mechanism description. 

Another option is to use the Reverse data bytes option. This option is able to switch the 
order of all complete bytes in used code. 

Use example: source code: 000000010412D123; final code: 00000023D1120401. 

Another option is to use the Single nibble bits mirroring. This option is able to switch the 
order of all bits in every nibble (nibble = bits quartet). 

Use example: source code: 000000010412D123; final code: 00000080284B84C. 

Another option is to use the Single byte nibbles mirroring. This option is able to switch the 
order of nibbles in every byte (switching bit quartets in every byte). 

Use example: source code: 000000010412D123; final code: 0000001040211D32. 

  

Pic. 7: User data format 
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5 Program operation 

After all configurations are finished, it is possible to start the server operation. The 
configuration is not saved by any special action; it is saved immediately after each 
configuration change. The configuration cannot be changed, if the server is started. 

The program can be run either as an application, or as a standard Windows service. It is 
not possible to use the program in both modes simultaneously. 

In the application mode the server is started by pressing the Start button at the top 
toolbar. To stop the server operation, press the Stop button. 

In the service mode all resources for operating the service are available after selecting the 
Service element in the configuration tree. 

When the program is operated in the application mode, all events, which happen while the 
server operates, are displayed at the Application server status tab, and also the events 
are saved in text log files. 

When the program is operated in the service mode, the events are only saved in the text 
log files. The directory containing the files can be opened with File > Open folder with Log 
files command. 

The program can be exited with File > Exit command. 

The information about the program version is available in the menu Help > About ID 
Microserver 2. 

Help can be displayed after selecting Help > Help (English) or Help > Nápověda (Czech). 


